股票指标_股票学习网【轻松赚钱】从此开始!

通达信公式-波段线

软件类型:国产软件 授权方式:免费软件 界面语言:简体中文 软件大小:8kb 日期时间:2018-01-04 10:36:20 点击次数:139 运行环境:通达信、大智慧、同花顺 软件等级:★★★☆☆ 下载次数:
软件介绍

通达信公式-波段线

通达信公式-波段线

通达信公式-波段线

通达信公式-波段线

通达信公式-波段线2

{波段线(通达信主图)}
 
N:=20;N1:=7;N2:=79;
MA7:MA(C,7),COLORMAGENTA,LINETHICK2;
MA89:MA(C,89),COLORBLUE,LINETHICK2;
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1:=(EMA(VAR1,3)+EMA(VAR1,6)+EMA(VAR1,12)+EMA(VAR1,24))/4;
A2:=EMA(A1,2);
A3:=EMA(A2,2);
A4:=EMA(A3,2);
A5:=EMA(A4,2);
A6:=EMA(A5,2);
A7:=EMA(A6,2);
IF(A1>REF(A1,1),A1,DRAWNULL),COLORRED;
IF(A1<REF(A1,1),A1,DRAWNULL),COLORGREEN;
IF(A2>REF(A2,1),A2,DRAWNULL),COLORRED;
IF(A2<REF(A2,1),A2,DRAWNULL),COLORGREEN;
IF(A3>REF(A3,1),A3,DRAWNULL),COLORRED;
IF(A3<REF(A3,1),A3,DRAWNULL),COLORGREEN;
IF(A4>REF(A4,1),A4,DRAWNULL),COLORRED;
IF(A4<REF(A4,1),A4,DRAWNULL),COLORGREEN;
IF(A5>REF(A5,1),A5,DRAWNULL),COLORRED;
IF(A5<REF(A5,1),A5,DRAWNULL),COLORGREEN;
IF(A6>REF(A6,1),A6,DRAWNULL),COLORRED;
IF(A6<REF(A6,1),A6,DRAWNULL),COLORGREEN;
IF(A7>REF(A7,1),A7,DRAWNULL),COLORRED;
IF(A7<REF(A7,1),A7,DRAWNULL),COLORGREEN;
压力:HHV(MA((L+H+C)/3,5),60),COLORCYAN,LINETHICK2;
JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
DRAWICON(REF(A<B,1) AND A>B,L*0.98,1);
{DRAWTEXT(REF(A<B,1) AND A>B,L,'--------------B'), COLORYELLOW;}
M3:=EMA(CLOSE,3);
M8:=EMA(CLOSE,8);
M13:=EMA(M8,13);
M55:=EMA(M8,55);
VAR1B:=EMA(M13,55);
M81:=EMA(M55,81);
M6:=EMA(VAR1B,144), COLORRED,LINETHICK2;
VAR2B:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR3B:=MA(CLOSE,N)+2*STD(CLOSE,N);
DRAWICON(CROSS(VAR2B,VAR3B),HIGH+0.1,2);
VAR4B:=REF(CLOSE,1);
VAR5B:=SMA(MAX(CLOSE-VAR4B,0),N1,1)/SMA(ABS(CLOSE-VAR4B),N1,1)*100;
VAR6B:=CROSS(N2,VAR5B);
VAR7B:=FILTER(VAR6B,4);
DRAWICON(VAR7B,HIGH+0.1,2);
ZTJZ:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
STICKLINE(ZTJZ AND COUNT(ZTJZ,13)>=1,C,O,1,0),COLORYELLOW;
DRAWTEXT(ZTJZ AND COUNT(ZTJZ,13)>=1,H*1.015,''),COLORYELLOW,LINETHICK1;
DRAWTEXT(ZTJZ AND COUNT(ZTJZ,13)>=1,H*1.028,''),COLORYELLOW;
YZFZ:=4;
YBLZ:=1.90;
DYKX:=C>O*(1+YZFZ/100) AND VOL>REF(VOL,1)*YBLZ;
LS0:=BARSLAST(DYKX);
BPJZ:=REF(L,LS0);
DRAWTEXT(DYKX,L-L*0.02,'阳'),COLOR00FFFF;
WZX1:=BPJZ *0.998;
WZX2:=BPJZ *0.98;
LS11:=IF(1,LS0=1,DYKX);
LS21:=IF(1,LLV(L,1)>REF(L,1),1);
DYBP:=LS11 AND LS21;
STICKLINE(DYBP,WZX1,BPJZ,4,0),COLORMAGENTA;
DRAWTEXT(DYBP,WZX2,'1'),COLORGREEN;
LS12:=IF(2,LS0=2,DYKX);
LS22:=IF(2,LLV(L,2)>REF(L,2),1);
DYBP2:=LS12 AND LS22;
STICKLINE(DYBP2,WZX1,BPJZ,4,0),COLORMAGENTA;
DRAWTEXT(DYBP2,WZX2,'2'),COLORGREEN;
LS13:=IF(3,LS0=3,DYKX);
LS23:=IF(3,LLV(L,3)>REF(L,3),1);
DYBP3:=LS13 AND LS23;
STICKLINE(DYBP3,WZX1,BPJZ,4,0),COLORMAGENTA;
DRAWTEXT(DYBP3,WZX2,'3'),COLORGREEN;
LS14:=IF(4,LS0=4,DYKX);
LS24:=IF(4,LLV(L,4)>REF(L,4),1);
DYBP4:=LS14 AND LS24;
STICKLINE(DYBP4,WZX1,BPJZ,4,0),COLORMAGENTA;
DRAWTEXT(DYBP4,WZX2,'4'),COLORGREEN;
LS15:=IF(5,LS0=5,DYKX);
LS25:=IF(5,LLV(L,5)>REF(L,5),1);
DYBP5:=LS15 AND LS25;
STICKLINE(DYBP5,WZX1,BPJZ,4,0),COLORMAGENTA;
DRAWTEXT(DYBP5,WZX2,'5'),COLORGREEN;
LS16:=IF(6,LS0=6,DYKX);
LS26:=IF(6,LLV(L,6)>REF(L,6),1);
DYBP6:=LS16 AND LS26;
STICKLINE(DYBP6,WZX1,BPJZ,4,0),COLORMAGENTA;
DRAWTEXT(DYBP6,WZX2,'6'),COLORGREEN;
LS17:=IF(7,LS0=7,DYKX);
LS27:=IF(7,LLV(L,7)>REF(L,7),1);
DYBP7:=LS17 AND LS27;
STICKLINE(DYBP7,WZX1,BPJZ,4,0),COLORMAGENTA;
DRAWTEXT(DYBP7,WZX2,'7'),COLORGREEN;
LS18:=IF(8,LS0=8,DYKX);
LS28:=IF(8,LLV(L,8)>REF(L,8),1);
DYBP8:=LS18 AND LS28;
STICKLINE(DYBP8,WZX1,BPJZ,4,0),COLORMAGENTA;
DRAWTEXT(DYBP8,WZX2,'8'),COLORGREEN;
LS19:=IF(9,LS0=9,DYKX);
LS29:=IF(9,LLV(L,9)>REF(L,9),1);
DYBP9:=LS19 AND LS29;
STICKLINE(DYBP9,WZX1,BPJZ,4,0),COLORMAGENTA;
DRAWTEXT(DYBP9,WZX2,'9'),COLORGREEN;
LS110:=IF(10,LS0=10,DYKX);
LS210:=IF(10,LLV(L,10)>REF(L,10),1);
DYBP10:=LS110 AND LS210;
STICKLINE(DYBP10,WZX1,BPJZ,4,0),COLORMAGENTA;
DRAWTEXT(DYBP10,WZX2,'10'),COLORGREEN;
DIF:=EMA(CLOSE,8)-EMA(CLOSE,13);
DEA:=EMA(DIF,6);
TCMACD:=2*(DIF-DEA);
GD1:=EVERY(DIF>REF(DIF,1),BARSLASTCOUNT(DIF>DEA))AND DIF>DEA;
GD2:=EVERY(TCMACD>REF(TCMACD,1),BARSLASTCOUNT(DIF>DEA))AND DIF>DEA;
GD:=MAX(GD1,GD2);
GDWZ1:=REF(MAX(C,O),BARSLAST(GD1)+1);
GDWZ2:=REF(MAX(C,O),BARSLAST(GD2)+1);
GDWZ:=IF(GDWZ2>=GDWZ1,GDWZ2,GDWZ1);
AA:=HHV(IF(C>O,C,MAX(C,O)),BARSLASTCOUNT(GDWZ)+1)=HHV(IF(C>O,C,MAX(C,O)),BARSLASTCOUNT(BBI>REF(BBI,1)AND C>BBI));
AA1:=REF(CLOSE,1);
压力2:DRAWLINE(BARSLAST(AA)=0,IF(C>O,C,MAX(C,O)),BARSNEXT(AA),REF(IF(C>O,C,MAX(C,O)),BARSLAST(AA)),1),DOTLINE,COLORYELLOW;
LD1:=EVERY(DIF<REF(DIF,1),BARSLASTCOUNT(DIF<DEA))AND DIF<DEA;
LD2:=EVERY(TCMACD<REF(TCMACD,1),BARSLASTCOUNT(DIF<DEA))AND DIF<DEA;
LD:=MIN(LD1,LD2);
DDWZ1:=REF(MIN(C,O),BARSLAST(LD1)+1);
DDWZ2:=REF(MIN(C,O),BARSLAST(LD2)+1);
DDWZ:=IF(DDWZ2<=DDWZ1,DDWZ1,DDWZ2);
BB:=LLV(IF(C<O,C,MIN(C,O)),BARSLASTCOUNT(LD)+1)=LLV(IF(C<O,C,MIN(C,O)),BARSLASTCOUNT(DIF<REF(DIF,1) AND BBI<REF(BBI,1)}AND L<BBI));
ZCWZ:DRAWLINE(BARSLAST(BB)=0,IF(C<O,C,MIN(C,O)),BARSNEXT(BB),REF(IF(C<O,C,MIN(C,O)),BARSLAST(BB)),1),DOTLINE,COLORGREEN;
DRAWNUMBER(ISLASTBAR,HHV(C,5)*0.95*1.015,HHV(C,5)*0.95),COLORWHITE;
STICKLINE(ISLASTBAR,HHV(C,5)*0.95-0.01,HHV(C,5)*0.95,50,0),COLORWHITE;
DRAWTEXT(ISLASTBAR,HHV(C,5)*0.95*0.99,'止损价位'),COLORWHITE;
MA60:=MA(C,60);
GLV60:=(C-MA60)/MA60*100;
DRAWTEXT_FIX(1,0.05,0.1,0,STRCAT('乖离率: ',CON2STR(GLV60,2))),COLORYELLOW;
DRAWTEXT_FIX(1,0.15,0.1,0,STRCAT(DYBLOCK,STRCAT('--',STRCAT(HYBLOCK,STRCAT('--',GNBLOCK))))),COLORYELLOW;
DRAWTEXT_FIX(1,0.05,0.15,0,STRCAT('市盈率:',CON2STR(DYNAINFO(39),2))),COLORRED;
DRAWTEXT_FIX(1,0.15,0.15,0,STRCAT('市净率:',CON2STR(C/FINANCE(34),2))),COLORRED;
下载地址
相关推荐
评论区域

来自南京的股民

东西确实很好用,有很多方面还需要学习, 服务也很好,值得拥有

来自扬州的股民

挺不错的一个指标

来自海口的股民

非常好,公式不错,一流。

来自中山的股民

不错的指标哦!选出的强势股涨幅都比较大。

来自巴中的股民

简单实用易学,正在观察,

下载说明

*如果这个软件总是不能下载的请点击报告错误,谢谢合作!!

*下载本站资源,如果服务器暂不能下载请过一段时间重试!

*本站提供的一些商业软件是供学习研究之用,如用于商业用途,请购买正版。

* 下载方法:在"下载地址"栏目中 点击"本地下载"即可。

* 本网发布的公式指标和股票软件绝大部分是来源于各大论坛,例如:LX论坛,LQZ论坛,CH论坛,MA**论坛等,谢谢各位老师的原创软件。

本网提供的公式文件说明:

* alg格式股票指标,———> 飞狐交易师股票软件引入使用;

* fnc格式股票公式,———> 大智慧新一代高速行情分析系统股票软件使用。

* exp格式股票公式,———> 仅可以用大智慧经典版股票软件引入使用;

* tnc和tni格式股票公式,———> 仅可以用通达信官方版本引入使用.

* tne格式公式,———> 可以用通达信公式编辑器5.0版导入,推荐通达信官方版本;

* hxf格式股票公式,———> 仅可以用同花顺股票软件引入使用。

以上的各种软件都可以在本网股票软件栏目找到并下载!

* 站内提供的所有软件均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们删除!

------分隔线----------------------------
栏目列表